Coding > FPC Valkyrie

Compiling won't work


Don Andy:
Soo, yah, I figured Valkyrie would be an awesome library to start making Roguelikes with, however, I can't get it to work, at all.

I got both the 0.8 as well as the 0.85 source of Berserk and tried to compile them with both the SVN Valkyrie version, as well as the 0.4.1 version (as it says in the readme) of the Valkyrie website, again to no avail.

Currently, I'm trying to compile with 0.8 Berserk and 0.4.1 Valkyrie and get the following error:

vutil.pas(86,64) Fatal: Syntax error, ) expected but = found

I've tried with multiple command line options, ranging from -Sc, -Sd over to -S2 but nothing seems to work :/

Also, I dunno if the tutorial on the website still is horribly out of date, but a new version would be kinda awesome. Nevertheless, a tutorial wouldn't be of much use if I can't even get the library itself to compile, so yeah xD

Sooo, after a lot of fiddling around, I came to the conclusion that I have the syntax switches (and all the other compiler stuff) set wrong. Sadly, I can't for the love of god figure out which settings work, so I'll keep trying.

Another Edit:
Everything SEEMS to work for now, except for one tiny thing, being the same error as in
The suggested solution is to use the SVN version of Valkyrie, which I AM using, so I'm kind of at a loss what to do there.

Kornel Kisielewicz:
Valkyrie and the open source projects using it (DiabloRL and Berserk!) will be updated soon. I plan to make Valkyrie more stable now, and more up to date.

Igor Savin:
How soon is "soon" (-: ?

BTW, updating for FPC 2.2.2 would win additional points of Awesome.

Kornel Kisielewicz:
2.2.2 has broken generics support ( ) , until it will be fixed, use the more stable 2.2.0.


[0] Message Index

Go to full version