DoomRL > Modding

Shotgun-style weapons not aiming properly?


Having a bit of a headache with this.  I've been trying to create a simple combat shotgun-like weapon, and while most everything functions properly, I cannot freeaim (outside of the adjacent squares) and I have to use "tab" to change target.  Is this a bug, or am I missing some important flag or property?  I've tried a bunch of silly things and even resorted to making up constants without success.  It almost seems like the shotgun is treated as a melee weapon, even though it is firing properly.

I also noticed the "Quake2" level has this problem.

We're pretty sure it's a bug.  Attempts to heckle Kornel about it haven't confirmed it yet though :)

Thanks for the quick reply.  Now I need to figure out a way to force the player to unload a weapon...

Haven't worked that one out either.  Finer loading/unloading controls are needed in my humble opinion.  Someone ought to put that in the requests thread.

Side note: IRC is a good place to brainstorm with modders.  It's where most of the sandbox abuse was first cooked up.


[0] Message Index

Go to full version