Chaosforge Forum

  • May 21, 2024, 12:59
  • Welcome, Guest
Please login or register.



Login with username, password and session length
Pages: [1]

Author Topic: [0.9.9.1] (Win) Crash bug, not exactly sure why...  (Read 1986 times)

FrostyTheDragon

  • Corporal
  • *
  • Offline Offline
  • Posts: 44
    • View Profile
[0.9.9.1] (Win) Crash bug, not exactly sure why...
« on: April 23, 2010, 09:32 »

This one comes from a game played on a Windows 7 (64-bit) laptop.

The only circumstance I know in this case was that I had just lost another character to errant barrel explosions (caused by a former human shot, it looks like), going from 52% to dead in the course of one action.  When trying to go to the mortem screen, this popped up:

An unhandled exception occurred at $004C1F6B
EAccessViolation : Access violation
  $004C1F6B  TBEINGAI__SCAN,  line 227 of doomai.pas
  $004C077B  TBEINGAI__RUN,  line 38 of doomai.pas
  $004AAc95  TBEING__ACTION,  line 622 of dfbeing.pas
  $0041B146  TDOOM__RUN,  line 409 of doombase.pas
  $004020B7  main, line 92 of doomrl.pas


The saved mortem file also says I died to a lost soul, but take a look at the graveyard screen from the mortem:

  ###########################################################
  ./....#.......#..../....#.......#....+....#.......#....####
  .#....#.......#..0.#....#.......#....#....#.......#....####
  .#..../......./....#..../......./....#....+.......+.;..####
  /#....#.......#....#....#.......#....#....#########...}####
  ./....#.......#...>/....#.......=....+....+.......+====####
  #####/####/####/#######/####+====X#######+####+####+#===###
  ./.......#.#......./...%...=.====..../.......#.#.....=0==##
  .#....%%.#.#.......#.....===.====....#.......#.#.##########
  .#.....%.#.#.......#........=====....#...|.;.+.+.#ssO.0####
  .#/#######/#######/#....%....#s|s....#########+#.#ss...####
  .+.......%...B...../.........#h.s...0/.........#.+sss..####
  #==##.####/####/#######+####/####.#######+####+####+#######
  ==.........#.......+.......#.#.......+.......#.#.......####
  .#=#######+#.......#^......#.#.#######.......#.#.##########
  .#......./......0..#...^...+.+.#h....#..}....+.+.#.....####
  .#...0...#.#.......#########+#.#.....#########+#.#.....####
  ./...0...#.#.......+.........#.+.....+.........#.+.....####
  ###########################################################
  ###########################################################

The only lost souls I see are well out of melee range, so I'm guessing the mortem bugged out when trying to determine what actually killed me, but I don't know.

If there's anything else I need to say, go ahead and let me know.  I still have the mortem file and my notes from this playthrough.
Logged

Malek Deneith

  • Grand Inquisitor Emeritus
  • Grand Inquisitor
  • Lieutenant General
  • *
  • *
  • Offline Offline
  • Posts: 1256
    • View Profile
Re: [0.9.9.1] (Win) Crash bug, not exactly sure why...
« Reply #1 on: June 14, 2010, 04:22 »

Created ticket #159, locking.
Logged
Inquisition - saving your soul, one bolter shell at a time.
Spoiler: "Hackmaster Kills" (click to show/hide)
Pages: [1]