Chaosforge Forum

  • January 21, 2019, 14:03
  • Welcome, Guest
Please login or register.



Login with username, password and session length
Pages: 1 2 [All]

Author Topic: Crash/bug topic  (Read 7802 times)

Frumple

  • Private
  • *
  • Offline Offline
  • Posts: 3
  • Lost Soul
    • View Profile
Crash/bug topic
« on: November 24, 2010, 14:03 »

Don't know if this is th'right place for it, but the read me does ask that we submit bugs and doesn't mention where to, so I'm starting up a topic.

--

Game crashed on me when I hit the Skeleton King with a level 4 holy bolt. As requested, I've attached what files I had, though it's only the .ini and log files -- I hadn't saved and the error file apparently didn't generate. Hope it helps, somehow.

Sorcerer rocks the house, by th'by. Wickedly powerful.
Logged

MDM

  • Lance Corporal
  • *
  • Offline Offline
  • Posts: 22
    • View Profile
Re: Crash/bug topic
« Reply #1 on: November 25, 2010, 05:47 »

I found that waiting using the "." does not work. It says "Unknown command. Read the help file!". Waiting using "Numpad 5" works.
Logged
Programmers don't die. They GOSUB WITHOUT RETURN!

SeventhShade

  • Private
  • *
  • Offline Offline
  • Posts: 2
  • Lost Soul
    • View Profile
Re: Crash/bug topic
« Reply #2 on: November 25, 2010, 13:53 »

Hi.  I got the same bug as Frumple.  I didn't hit the Skeleton King with anything, it just crashed shortly after seeing the king.  It also erased my saved game :/
Logged

skarczew

  • Elder
  • Major General
  • *
  • *
  • Offline Offline
  • Posts: 974
    • View Profile
Re: Crash/bug topic
« Reply #3 on: November 25, 2010, 17:44 »

How to waste your good character:

1. Open quickslot '`'
2. Move highlited option to "close" (with cursor keys)
3. Press any of keys: 1-8

Gratz, you just lost your character with save file!


Another issue I noticed: Mana shield stops working after game load :( .
Logged

ParaSait

  • Baffen :P
  • Elder
  • Lieutenant General
  • *
  • *
  • Offline Offline
  • Posts: 1223
  • Happy Little Boozer
    • View Profile
    • MPSF
Re: Crash/bug topic
« Reply #4 on: November 25, 2010, 20:20 »

I found that waiting using the "." does not work. It says "Unknown command. Read the help file!". Waiting using "Numpad 5" works.
Isn't that simply cause the keys are just bound like that? You can edit em in the ini.
Logged
[18|7|3|0|0|0] [MED:13/43] [SPE:36/67] [ASM:11/40]

Check out my epic youtube channel!
Currently playing The Bard's Tale and System Shock 2 (coop with GrAV1t)!

MDM

  • Lance Corporal
  • *
  • Offline Offline
  • Posts: 22
    • View Profile
Re: Crash/bug topic
« Reply #5 on: November 26, 2010, 02:08 »

If I unpack the game from .zip, then I expect the game to work like I read it in the manual. So I gues it's a bug in the manual? *g*
Logged
Programmers don't die. They GOSUB WITHOUT RETURN!

ParaSait

  • Baffen :P
  • Elder
  • Lieutenant General
  • *
  • *
  • Offline Offline
  • Posts: 1223
  • Happy Little Boozer
    • View Profile
    • MPSF
Re: Crash/bug topic
« Reply #6 on: November 26, 2010, 08:50 »

If I unpack the game from .zip, then I expect the game to work like I read it in the manual. So I gues it's a bug in the manual? *g*
Oh, right, I get what you mean. I guess that's not really a bug, more like a little slip in the manual.
Logged
[18|7|3|0|0|0] [MED:13/43] [SPE:36/67] [ASM:11/40]

Check out my epic youtube channel!
Currently playing The Bard's Tale and System Shock 2 (coop with GrAV1t)!

skarczew

  • Elder
  • Major General
  • *
  • *
  • Offline Offline
  • Posts: 974
    • View Profile
Re: Crash/bug topic
« Reply #7 on: November 26, 2010, 11:30 »

Minor issues:
1.
Manual does not display correctly quotes:
s

But it does correctly displays quotes:
'z'

(Incosistency btw, there should be one type of quotes).

2. At the start of game I have "staff of firebolt". Later in the game I found "staff of Firebolt". Is there any difference?
« Last Edit: November 26, 2010, 19:14 by skarczew »
Logged

you

  • Programmer
  • Local Inquisitor
  • First Sergeant
  • *
  • *
  • Offline Offline
  • Posts: 108
  • I am You!
    • View Profile
Re: Crash/bug topic
« Reply #8 on: November 26, 2010, 11:39 »

skarczew: yes, there is difference in recharge cost (f/F misconsistency would be fixed in future versions)
Logged

skarczew

  • Elder
  • Major General
  • *
  • *
  • Offline Offline
  • Posts: 974
    • View Profile
Re: Crash/bug topic
« Reply #9 on: November 26, 2010, 19:50 »

there is difference in recharge cost
Could be nice if there was some explanation of this ...

Another (major) issue:

3. Crashes. Try few times to load the save - sometimes it works.

File attached.
Logged

you

  • Programmer
  • Local Inquisitor
  • First Sergeant
  • *
  • *
  • Offline Offline
  • Posts: 108
  • I am You!
    • View Profile
Re: Crash/bug topic
« Reply #10 on: November 27, 2010, 03:12 »

Skeleton King crashes the game. Avoid him if you can. Sorry for that bug, me could not test all the issues by myself.

The recharge cost for unique staves and sorc's starting staff does not include the price of available charges.
Logged

skarczew

  • Elder
  • Major General
  • *
  • *
  • Offline Offline
  • Posts: 974
    • View Profile
Re: Crash/bug topic
« Reply #11 on: November 27, 2010, 05:33 »

I managed to kill Skel King somehow with Holy Bolt (which was said to be bugged - but I did not face any problems here).

Another possible problem (cannot recheck because save was lost):

4. I broke the barrel next to monster and it exploded. Monster was damaged/killed in the process and the game crashed.
Logged

Skiv

  • Elder
  • Private FC
  • *
  • *
  • Offline Offline
  • Posts: 9
  • Lost Soul
    • View Profile
Re: Crash/bug topic
« Reply #12 on: November 27, 2010, 21:59 »

My guess is that Skeleton King Crash bug occurs when the said King spawns a minion. Since the spawning seems to be a random event, I lived through the fight by means of save'n'load (the cheater I am). Save after each successful hit, load if crashes. Hope that helps.
« Last Edit: November 28, 2010, 00:12 by Skiv »
Logged

skarczew

  • Elder
  • Major General
  • *
  • *
  • Offline Offline
  • Posts: 974
    • View Profile
Re: Crash/bug topic
« Reply #13 on: November 28, 2010, 10:11 »

5. Ogden almost always starts every conversation (when you get back to town from dungeon) with wall of text "Thank goodness you've returned! blah blah blah (...)". One time is not enough?

6. Another crash: when you give tavern sign to Ogden and save, game crashes during save creation - and save becomes corrupted.
Check out save file (before giving sign to Ogden).

7. "the <monster> <monster_action>". For example:
"the hidden appears"

Should be "The", as this is the start of a sentence.
Logged

you

  • Programmer
  • Local Inquisitor
  • First Sergeant
  • *
  • *
  • Offline Offline
  • Posts: 108
  • I am You!
    • View Profile
Re: Crash/bug topic
« Reply #14 on: November 28, 2010, 12:05 »

Harlequin Crest crash on save confirmed. Thank you for your report.
Logged

saufnix

  • Private
  • *
  • Offline Offline
  • Posts: 1
  • Lost Soul
    • View Profile
Re: Crash/bug topic
« Reply #15 on: April 12, 2011, 06:56 »

Hi.  I got the same bug as Frumple.  I didn't hit the Skeleton King with anything, it just crashed shortly after seeing the king.  It also erased my saved game :/
Hi!
Thank you for the great game. I had the same problem :( - the game crashed shortly after seeing the Skeleton King. Luckily I had the save game. When you step 2 characters up, the game always chashes. I'm using Debian/squeeze on an amd64.
Logged

Blood

  • Elder
  • Private FC
  • *
  • *
  • Offline Offline
  • Posts: 10
  • 2Defender
    • View Profile
Re: Crash/bug topic
« Reply #16 on: December 01, 2012, 15:05 »

Impossible to load a save game. My game crash when try it. It's with sound version.

On classical without sound I can save and load after.
Logged
Sorry for my english : translate.google is my friend.

ryballs

  • Private FC
  • *
  • Offline Offline
  • Posts: 7
  • Lost Soul
    • View Profile
Re: Crash/bug topic
« Reply #17 on: May 21, 2013, 02:02 »

After loading a game where I was standing in front of a portal I got an error (which I ignored as it wasn't fatal).. I think it was error in a lua file (next time I will screen shot). I then went down portal did some looting, went back to town, tried to go down portal again and it crashed the game. Now I can't load my saved game which is a pity as I was going quite well :(

Bugged Save Game: http://cl.ly/1z443a2K3W2F
Logged

Psojed

  • DiabloRL Beta Tester
  • Corporal
  • *
  • Offline Offline
  • Posts: 40
  • User #2000, Level 60 Paladin
    • View Profile
Re: Crash/bug topic
« Reply #18 on: May 21, 2013, 02:03 »

You can find all the errors in the error.log file.
Logged

ryballs

  • Private FC
  • *
  • Offline Offline
  • Posts: 7
  • Lost Soul
    • View Profile
Re: Crash/bug topic
« Reply #19 on: May 21, 2013, 02:11 »

You can find all the errors in the error.log file.

Thanks for that. :) I noticed that the error.log filed is stored in 'Applications' which is very unusual for an osx app. Generally they are stored in ~/Documents/<Game Name>. Anyway here is a copy/paste of my error.log.. The earlier errors are when I first got an error after loading and the latter I think is occurring now that I can't load the save.

Timestamp   : 21-5-13 11:11:02
Error level : ERROR
Message     : Lua hook OnEnter caught ELuaStateException!

Call path     : levels[town].OnEnter
Call params   : (true)
Error message : Lua error : lua/levels//town.lua:189: Position expected!

Timestamp   : 21-5-13 11:23:49
Error level : ERROR
Message     : Lua hook OnEnter caught ELuaStateException!

Call path     : levels[town].OnEnter
Call params   : (false)
Error message : Lua error : lua/levels//town.lua:189: Position expected!

Timestamp   : 21-5-13 11:28:18
Error level : FATAL EXCEPTION
Message     : Fatal exception encountered

An unhandled exception occurred at $0000000100040E4B :
EInvalidCast : Invalid type cast
  $0000000100040E4B

Timestamp   : 21-5-13 11:28:28
Error level : FATAL EXCEPTION
Message     : Fatal exception encountered

An unhandled exception occurred at $0000000100041BD9 :
EAccessViolation : Access violation
  $0000000100041BD9
Logged

siwucha

  • Lance Corporal
  • *
  • Offline Offline
  • Posts: 24
  • Lost Soul
    • View Profile
Re: Crash/bug topic
« Reply #20 on: May 23, 2013, 18:40 »

I played through 0.5.0 and while everything works mostly fine, there were some lua errors when fighting zhar the mad:
Code: [Select]
----------------------------------------------------------------------
Timestamp   : 23-5-13 22:20:10
Error level : ERROR
Message     : Lua hook OnAct caught ELuaException!

Call path     : npcs[zhar_the_mad].OnAct
Call params   : ()
Error message : Path [(spells,0)] passed to TLuaTable is nil!
----------------------------------------------------------------------

(repeat several hundred times)

I also got lua errors similiar to that when using the guardian spell (unfortunately these are no longer in the error.log, I think I accidentially deleted it). Didn't seem to affect gameplay too much, but guardian spell doesn't work.

Logged

levelworm

  • Private
  • *
  • Offline Offline
  • Posts: 1
  • Lost Soul
    • View Profile
Re: Crash/bug topic
« Reply #21 on: June 25, 2013, 21:14 »

Hi, this is a fantastic game but I did get one bug. Honestly I'm not sure how it happened but when I was on low HP and attack a barrel which exploded, the game crashed. I did not save the game so I had to restart, which is OK. I'm not sure whether I got killed by the explosion though (so it could be a feature instead of a bug). I tried to find the "error.log" but could not find it.
Logged
Pages: 1 2 [All]