DoomRL > Requests For Features


(1/2) > >>

Kornel Kisielewicz:
High time to start working on another release, don't you think?

There are some old changes in the repository that never were publicly tested, so I need a baseline BETA 1 tested to go further. Also this version includes changes to linux curses display (you'll need to compile it yourself to check it out). Changelog below.

DoomRL BETA 1 Windows LQ

If you're not on Windows, you can always compile the development branch from github - find me on the Jupiter Hell discord if you need help with that!

--- Code: --- BETA 1
[new] -- TR#307: description for badges and medals in mortem.txt
[new] -- TR#---: event added: darkness
[mod] -- TR#---: Nightmare no longer prevents saving
[mod] -- TR#---: animation engine upgrade
[mod] -- TR#294: targeting ranges use vision calculation and are locked to vision range unless the weapon specifies a different range (shark)
[mod] -- TR#310: character screen (@) shows dodge and knockback modifiers.
[mod] -- TR#---: Ao100 / AAo666 full wins now counted as such.
[mod] -- TR#---: AoOC retooled -- starting inventory changed.
[mod] -- TR#---: separte path support (separate data/score etc, esp on Linux)
[mod] -- TR#---: curses used on Linux instead of FPCVideo
[fix] -- TR#---: melee kills tracked properly AoLT and ArchAoLT now working as intended
[fix] -- TR#---: kills are only assigned to an item if the item was used to kill
[fix] -- TR#---: weapon OnKill is called only if weapon is used to kill the enemy
[fix] -- TR#154: plural items (boots) are now properly described on floor
[fix] -- TR#---: fixed mouse scrolling along map edges (shark)
[fix] -- TR#---: right click won't try to reload weapons that don't use ammo (shark)
[fix] -- TR#290: mouse targeting now respects missile range property and vision range (shark)
[fix] -- TR#290: targeting line has consistent coloring rules between console and graphics mode.
[fix] -- TR#303: SegFault from melee attacking during weapon restricted challenges fixed (shark)
[fix] -- TR#---: better timed explosion animations for weapons firing multiple shots (shark)
[fix] -- TR#---: pump action weapons that self charge or don't use ammo will allow 'r' to pump them (shark)
[fix] -- TR#---: Shottyman no longer move-reloads self charging weapons (shark)
[fix] -- TR#---: BFG10K has better scattering, and scatters at close range (shark)
[fix] -- TR#303: Fixed a crash caused by a weird interaction between the player's death, a nuke, and being OnAction hooks (shark)
[fix] -- TR#---: 'l'ooking no longer overwrites the last line of the message log (shark)
[fix] -- TR#---: Repeat level feeling command added (Shift-L by default) (shark)
[fix] -- TR#---: Hell's Armory/Deimos Lab can now generate a unique as its special item.
[fix] -- TR#311: Armory/Deimos Lab won't pick assemblies created in the current game as a schematic choice.
[fix] -- TR#---: MMB now properly performs both attacks always. (shark)
[fix] -- TR#---: Demons shouldn't freeze up any more.
[fix] -- TR#---: Vaults: Opened spaces no longer marked permanent.
[fix] -- TR#---: Deimos Lab: Schematic generation matches Armory rules.
[fix] -- TR#---: Military Base: Work around for graphics issues.
[fix] -- TR#---: Arch-Viles now take damage from acid/lava.
[fix] -- TR#---: Berserker trigger is based on Nominal HP (Iro/Marine will no longer affect it), still has minimum of 10 damage (for AoHu).
[fix] -- TR#309: AoOC now counts sacrifice and full wins properly.
[fix] -- TR#---: Technicians now get starting tech mod on challenges that were (incorrectly) removing it.

--- End code ---

Omega Tyrant:
In case all of these weren't seen when I posted about them in the Discord server, I'll report the bugs here that I encountered after completing a standard game and A100 game in this beta.

BUG #1

The newly added "repeat level feeling" command does not seem to work:

Spoiler (click to show/hide)
The error message in the error log is:

--- Code: ---Timestamp   : 9/1/2023 23:22:41
Error level : CRITICAL
Message     : Player action exception!

Error message : ...0\Downloads\doomrl-win-0998-beta1-lq\keybindings.lua:69: attempt to call field 'repeat_feel' (a nil value)
--- End code ---

BUG #2

When stepping into damaging fluids with fluid-immune boots, you get the fluid damage message and pain sound despite taking no damage. Aside from general annoyance, this does have a gameplay impact, as the game prevents you from doing run -> wait on acid/lava with fluid-immune boots, with it thinking you're getting damaged each action. This bug did not exist in and so is definitely newly introduced from this beta. Here are a couple screenshots showing it:

Spoiler (click to show/hide)Spoiler (click to show/hide)
I'll also note this bug does not occur when you have the envirosuit effect active.

BUG #3

While one of the fixes listed in the changelog is adjusting the Pinky's AI to no longer get stuck, I can confirm that they still do. Here are a couple screenshots from Phobos Lab showing how they were bunched up together in the cave, unable to get out after I run -> waited several times to see if they would get out (well before and after the fact, I forgot to take the screenshot when they were all on screen alive at once):

Spoiler (click to show/hide)Spoiler (click to show/hide)
I'll also note I observed Pinkies getting stuck in other levels. Personally I am fine with the Pinkies' AI as it was, as I do think it gives them a unique "ambush"-like behavior, and Phobos Lab in particular would lose a lot of its fear factor if you didn't need to go into the cave to flush the Demons out, but I noted it in case the majority do want their AI fully fixed.

BUG #4

I would get this error message whenever enemies seemingly kills themselves from barrels or their own splash damage. Here's a screenshot from one of the instances:

Spoiler (click to show/hide)
And here are a few of the error messages related to this bug from the error log:

--- Code: ---Timestamp   : 9/2/2023 2:23:46
Error level : ERROR
Message     : Lua hook OnAttacked caught ELuaStateException!

Call path     : beings[baron].OnAttacked
Call params   : (<object>,<object>)
Error message : Lua error : attempt to call a table value
--- End code ---

--- Code: ---Timestamp   : 9/2/2023 2:24:38
Error level : ERROR
Message     : Lua hook OnAttacked caught ELuaStateException!

Call path     : beings[soldier].OnAttacked
Call params   : (<object>,<object>)
Error message : Lua error : attempt to call a table value
--- End code ---

--- Code: ---Timestamp   : 9/3/2023 18:06:58
Error level : ERROR
Message     : Lua hook OnAttacked caught ELuaStateException!

Call path     : beings[arch].OnAttacked
Call params   : (<object>,<object>)
Error message : Lua error : attempt to call a table value
--- End code ---

--- Code: ---Timestamp   : 9/4/2023 20:48:47
Error level : ERROR
Message     : Lua hook OnAttacked caught EAccessViolation!

Call path     : beings[revenant].OnAttacked
Call params   : (<object>,<object>)
Error message : Access violation
--- End code ---

BUG #5

In my A100 run, the killing spree tracker got frozen at one point, and remained that way for the rest of the run. Here are two screenshots from different times showing it stuck at 112:

Spoiler (click to show/hide)Spoiler (click to show/hide)

That's everything for now, if I encounter any more bugs, I'll report them here.

BUG #6

"Technicians now get starting tech mod on challenges that were (incorrectly) removing it."

This appears to be working exactly the same as version The Technical Mod Pack is still removed for various challenges that wipe your inventory before replacing it.

Omega Tyrant:
BUG #7

When playing Angel of Marksmanship on UV, I have encountered a game breaking bug, where upon killing Carmack, the game crashes. However, instead of counting the win and producing a mortem, the game creates a backup save from at the start of Hell Fortress, with me at the same state I was in when I killed Carmack.

Here's a screenshot from right before I kill Carmack:

Spoiler (click to show/hide)
And here's a screenshot from booting up that save, notice how my health and armor are in the same exact state at which I killed Carmack (but my Combat Pistol is reloaded because I have Gun Kata, which apparently still reloaded after killing Carmack before the crash occurs).

Spoiler (click to show/hide)
If I kill Carmack again upon booting this save, the game will crash again and create another backup save, leading to an unwinnable game loop. I'll also note that I did not save when first entering Hell Fortress, and that I have gotten a full win before on this beta, so it's not just getting a full win itself that's broken. After killing him a few more times and getting a crash everytime, I just let myself die, where the game crashed and tried creating a backup save yet again. Trying to boot up this save though resulted in this corrupted save notification:

Spoiler (click to show/hide)
Here's what the actual error message is for this crash:

--- Code: ---Timestamp   : 9/8/2023 4:47:07
Message     : Fatal exception encountered

An unhandled exception occurred at $000000010006F057 :
ELuaException : Get( failed!
  $000000010006F057  GET,  line 1408 of ../fpcvalkyrie/src/vluasystem.pas
  $00000001000A72F4  WEAPONGROUP,  line 814 of src/dfhof.pas
  $00000001000A67F9  ADD,  line 850 of src/dfhof.pas
  $00000001000CE65A  WRITEMEMORIAL,  line 1114 of src/dfplayer.pas
  $000000010002AC28  RUN,  line 356 of src/doombase.pas
  $0000000100002230  main,  line 147 of src/doomrl.pas
--- End code ---

BUG #8

After the corrupted save and the game deleting it, no mortem was saved, but I noticed some oddities with my player stats afterward.

First, it still awarded me the Marksman badges:

Spoiler (click to show/hide)
This is however despite the game not counting the win:

Spoiler (click to show/hide)
Then I have achieved the conditions to rank up, but the game has not upgraded my rank, despite it showing me having all the requisites for the next rank:

Spoiler (click to show/hide)
Then all the exotics and uniques I collected during the run were counted, but have their collected number inflated. Notice the ones here with a collected number of 9 or more, when I haven't even played that many games yet on this file:

Spoiler (click to show/hide)
The same bug applies to assemblies too (Nanomanufacture Ammo is counted as having been made 9 times, but this was the first time I assembled it on this file):

Spoiler (click to show/hide)
My medal counts have a similar inflation bug:

Spoiler (click to show/hide)
Then my kill counts are all fucked up. It says I killed 45 Carmacks on UV, which is obviously bogus, but then the 10 Mastermind kills are inflated as well, and it also says I haven't killed the Arena Master on UV, even though I did so this run (and I'll note that I did not go through the crash to save loop 45 times before dying, I did so only about like 5 or 6 times):

Spoiler (click to show/hide)
Well that's everything I can see for now, I'll report if I find any more oddities as a result of this game-ending crash.

BUG #9

While not truly a bug, I think the hindrance is significant enough to be considered one.

When you get Tracking Map, movement and general gameplay can be extremely slow when there are lots of enemies. I had one floor with a single Pain Elemental that stuttered my movement a lot and even firing was much slower. I've never experienced this in older versions.


[0] Message Index

[#] Next page

Go to full version