Chaosforge Forum

  • July 12, 2024, 17:41
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Pages: [1]

Author Topic: down  (Read 235 times)


  • Backer
  • Private
  • *
  • *
  • Offline Offline
  • Posts: 3
  • Lost Soul
    • View Profile down
« on: July 02, 2024, 15:31 »


I was wondering why DoomRL "wasn't working". It was stuck on the black console window at start, without showing signs of loading, and I tended to close it after maybe 10 seconds (when it used to insta-load, before).

I uninstalled, reinstalled - same behavior. And I didn't get any log (the log.txt file stayed at 0 bytes)

I tried to run it a number of times, without getting anything. Then, on another try (don't know why it finally "worked" - maybe some "max retrys" setting, or something getting cached), after waiting for about 15 seconds, I got the popup asking me if I wanted to run full-screen, and the game started.

I closed the game, and looked at the log.txt file, and I saw the cause for the 15-seconds wait:

23:26:32 : INFO    : <TDownloadTask> DoomNet: downloading to C:\Program Files (x86)\DoomRL\info.xml...
23:26:51 : INFO    : <TDownloadTask> DoomNet: ESocketError caught - Receive from "" failed (10060)

I've noticed the website is now, but trying the URL changing the .net to .org leads me to an error page, on my browser.

So, changing the NetworkConnection = true to false in config.lua worked, and the game then started without any delay - but is there any plan to fix this ?

Kornel Kisielewicz

  • God Hand
  • Apostle
  • *
  • *
  • Offline Offline
  • Posts: 4565
    • View Profile
Re: down
« Reply #1 on: July 03, 2024, 09:56 »

Yeah, the whole network part will be removed for the next version. In the meantime NetworkConnection = false is the official fix.

I still dunno why it suddenly stopped working though, for more than a decade it simply timed out immedately.
at your service,
Kornel Kisielewicz
Pages: [1]