Chaosforge Forum

  • December 14, 2019, 11:17
  • Welcome, Guest
Please login or register.



Login with username, password and session length

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Don Andy

Pages: [1]
1
FPC Valkyrie / Compiling won't work
« on: June 25, 2008, 00:45 »
Soo, yah, I figured Valkyrie would be an awesome library to start making Roguelikes with, however, I can't get it to work, at all.

I got both the 0.8 as well as the 0.85 source of Berserk and tried to compile them with both the SVN Valkyrie version, as well as the 0.4.1 version (as it says in the readme) of the Valkyrie website, again to no avail.

Currently, I'm trying to compile with 0.8 Berserk and 0.4.1 Valkyrie and get the following error:

vutil.pas(86,64) Fatal: Syntax error, ) expected but = found

I've tried with multiple command line options, ranging from -Sc, -Sd over to -S2 but nothing seems to work :/

Also, I dunno if the tutorial on the website still is horribly out of date, but a new version would be kinda awesome. Nevertheless, a tutorial wouldn't be of much use if I can't even get the library itself to compile, so yeah xD

Edit:
Sooo, after a lot of fiddling around, I came to the conclusion that I have the syntax switches (and all the other compiler stuff) set wrong. Sadly, I can't for the love of god figure out which settings work, so I'll keep trying.

Another Edit:
Everything SEEMS to work for now, except for one tiny thing, being the same error as in http://forum.chaosforge.org/index.php?topic=977.0
The suggested solution is to use the SVN version of Valkyrie, which I AM using, so I'm kind of at a loss what to do there.

Pages: [1]