Chaosforge Forum

  • January 26, 2020, 10:41
  • Welcome, Guest
Please login or register.



Login with username, password and session length
Pages: [1]

Author Topic: The game quits responding  (Read 3538 times)

Dork

  • Private
  • *
  • Offline Offline
  • Posts: 2
    • View Profile
The game quits responding
« on: March 10, 2008, 00:52 »

I am playing DoomRL version 0.9.8.9 on Linux Mint.  It is basically Ubuntu 7.1
I can run DoomRL windows version using wine with no problems, but I have been trying to use your Linux binary.

The game seems to run fine using the Linux binary.  The problem is the game seems to lockup after a few minutes of play.  It is usually within the first or second level of the game. I believe it is even close the the same amount of turns each time it freezes.

I usually tell within around ten turns or less of when the game will freeze.  First the game will have a few second lag of a command, after that it runs fine for about ten turns.  Afterward, it just quits responding. I can't even get escape sequences to work with the terminal when this happens.

Anybody got any ideas, just let me know if you need more info.
Logged

ParaSait

  • Baffen :P
  • Elder
  • Lieutenant General
  • *
  • *
  • Offline Offline
  • Posts: 1223
  • Happy Little Boozer
    • View Profile
    • MPSF
Re: The game quits responding
« Reply #1 on: March 10, 2008, 11:43 »

Exactly how long does it take before the game freezes (not in turns, but in real time) ?
Logged
[18|7|3|0|0|0] [MED:13/43] [SPE:36/67] [ASM:11/40]

Check out my epic youtube channel!
Currently playing The Bard's Tale and System Shock 2 (coop with GrAV1t)!

Kornel Kisielewicz

  • God Hand
  • Apostle
  • *
  • *
  • Online Online
  • Posts: 4497
    • View Profile
    • http://chaosforge.org/
Re: The game quits responding
« Reply #2 on: March 10, 2008, 15:24 »

With or without music/sound?
Logged
at your service,
Kornel Kisielewicz

Dork

  • Private
  • *
  • Offline Offline
  • Posts: 2
    • View Profile
Re: The game quits responding
« Reply #3 on: March 10, 2008, 17:42 »

I have tried it with the sound and no sound versions.  I would  say it takes about 5 minutes or so before it freezes.  I can't check right now.  I am taking a few minute break from some work.  If no one has any ideas, I can take a video of me playing.
Logged

Macuyiko

  • Private
  • *
  • Offline Offline
  • Posts: 1
    • View Profile
Re: The game quits responding
« Reply #4 on: March 11, 2008, 12:13 »

I have the exact same problem, using Ubuntu Gutsy.

Quote
First the game will have a few second lag of a command, after that it runs fine for about ten turns.  Afterward, it just quits responding.
Same here.
Logged

curtmack

  • Private
  • *
  • Offline Offline
  • Posts: 4
    • View Profile
Re: The game quits responding
« Reply #5 on: January 08, 2009, 16:07 »

Problem hasn't gone away, I'm experiencing the same problem with version 0.9.8.10 on Ubuntu Intrepid.
Logged

007bistromath

  • Backer
  • First Lieutenant
  • *
  • *
  • Offline Offline
  • Posts: 221
    • View Profile
Re: The game quits responding
« Reply #6 on: January 09, 2009, 00:25 »

Have you tried saving after the first level to see if that affects the amount of time/turns it takes to fail?
Logged

curtmack

  • Private
  • *
  • Offline Offline
  • Posts: 4
    • View Profile
Re: The game quits responding
« Reply #7 on: January 09, 2009, 17:15 »

Have you tried saving after the first level to see if that affects the amount of time/turns it takes to fail?

I saved after first level, and after that, it didn't seem to freeze up on second level. When I saved on second level, it printed out this error message: "write to (obscured by ASCII Doom logo) /dev/sequencer," but otherwise the save was successful. Also, there is a noticeable lag when loading a savegame (about 2 seconds). And sometimes I have to press keys twice (especially Escape, when cancelling out of something) for them to have an effect.
Logged

curtmack

  • Private
  • *
  • Offline Offline
  • Posts: 4
    • View Profile
Re: The game quits responding
« Reply #8 on: January 09, 2009, 17:25 »

Just froze up on level 4. I'm not sure if there's any pattern to how it occurs. But I did notice the same thing - first, there's a several seconds of lag after making a move, and then, 10-20 moves later, it completely freezes. There doesn't seem to be anything in log.txt that explains it.
Logged

007bistromath

  • Backer
  • First Lieutenant
  • *
  • *
  • Offline Offline
  • Posts: 221
    • View Profile
Re: The game quits responding
« Reply #9 on: January 10, 2009, 01:29 »

Check on your system resources while running the game, especially when it gets laggy. This is starting to sound like a memory leak.
Logged

curtmack

  • Private
  • *
  • Offline Offline
  • Posts: 4
    • View Profile
Re: The game quits responding
« Reply #10 on: January 10, 2009, 11:08 »

Check on your system resources while running the game, especially when it gets laggy. This is starting to sound like a memory leak.

Memory and CPU usage both remain pretty constant, even when the game is lagging.
Logged

LogicalDash

  • Private
  • *
  • Offline Offline
  • Posts: 1
    • View Profile
Re: The game quits responding
« Reply #11 on: February 20, 2009, 10:16 »

The game is now running non-freezing-ly for me, under Ubuntu Intrepid, with the sound turned off and the sound and music header files commented out in doomrl.ini.
Logged
Pages: [1]