Chaosforge Forum

  • November 14, 2019, 04:53
  • Welcome, Guest
Please login or register.



Login with username, password and session length
Pages: [1]

Author Topic: (0.9.9) Midi mixer volume on music change  (Read 827 times)

InT

  • Silver Supporter
  • Supporter
  • Private
  • *
  • *
  • Offline Offline
  • Posts: 1
  • Lost Soul
    • View Profile
(0.9.9) Midi mixer volume on music change
« on: October 23, 2009, 05:35 »

doomrl 0.9.9, win32, XPsp3, SB Audigy

I'm enjoying 0.9.9 so far, except for a small glitch: every time the music playback changes tracks, the game changes the MIDI mixer setting. My audio setup basically requires the midi volume to be 100% to hear it, but out of the box 0.9.9 set it to roughly 25% of full.

I changed MusicVolume to 25, the documented maximum; doomrl then set the mixer to half volume. Setting MusicVolume to 50 didn't get any more volume than that ;) . Upping the MIDI volume to maximum in the mixer afterwards works, of course... until the game changes the music track, cutting it back down again.

Is there anything else I can do to work around this, or is it a code problem?
« Last Edit: October 24, 2009, 22:43 by InT »
Logged

Malek Deneith

  • Grand Inquisitor Emeritus
  • Grand Inquisitor
  • Lieutenant General
  • *
  • *
  • Offline Offline
  • Posts: 1256
  • Lost Seraph
    • View Profile
Re: (0.9.9) Midi mixer volume on music change
« Reply #1 on: November 10, 2009, 14:17 »

Judging by Kornel's response to a similar question here, it's an fmod issue not DoomRL code issue. Ergo: Nothing can be done, locking
Logged
Inquisition - saving your soul, one bolter shell at a time.
Spoiler: "Hackmaster Kills" (click to show/hide)
Pages: [1]