Chaosforge Forum

  • August 10, 2020, 22:33
  • Welcome, Guest
Please login or register.



Login with username, password and session length
Pages: [1]

Author Topic: Display problems--SOLVED!!  (Read 1521 times)

action52

  • Elder
  • Sergeant
  • *
  • *
  • Offline Offline
  • Posts: 62
  • Lost Soul
    • View Profile
Display problems--SOLVED!!
« on: January 13, 2010, 22:47 »

I'm a huge fan of both Doom and roguelikes. Recently I finally downloaded DoomRL. It seems like a game I would really love, but unfortunately I am having trouble with the display on my computer. First, here is a screenshot taken with the "F9" key. This is what I SHOULD be seeing.


The former human fires! Boom! The former human fires! You are hit!             
 Screenshot created.                                                           
 ##############################################################################
 #............................................................................#
 #............................................................................#
 #............................................................................#
 #.........................########...........................................#
 #.........................#      #########...................................#
 #.........................#      /.......#...................................#
 #......................####        .h....#######.............................#
 #......................#             #...#.....#.............................#
 #......................#             #...@...../.............................#
 #......................#             #...#.....#.............................#
 #......................####        ..h...#######.............................#
 #.........................#      /.h.....#...................................#
 #.........................#      #########...................................#
 #.........................########...........................................#
 #............................................................................#
 #............................................................................#
 #............................................................................#
 #............................................................................#
 ##############################################################################
 Adam Ring                  Armor : none                                       
 Health: 87%  Exp:  1/0%    Weapon: pistol (2d4) [6/6]                         
 cautious                                                    Phobos Base Entry 


Next, this is a screenshot image of my screen. This is what I am ACTUALLY seeing:



Notice how two of the former humans, and some of the walls, and my own character, are not displayed? And the dots that make up the floor are extra wide, taking up two spaces each.

I am running this game in Windows Vista, on a Japanese computer. Japanese computers interpret a lot of ASCII characters differently. For example, in games like Nethack, the backslash always comes out as a "yen" symbol. And if I set the display options to "IBMGraphics" I get all sorts of random Japanese characters.

It looks like something similar to this is happening here. Japanese computers have a "wide" font for characters. This is because the standard font size is too small to display kanji properly, so they can switch the display to "wide" mode for Japanese text.

It looks like certain floor tiles are being displayed in "wide" mode, and that objects will only be displayed if they align a certain way with the floor tiles. So half of all objects are invisible! The game is pretty much unplayable this way. I'm getting shot by invisible sergeants, missing essential items, and getting blown up by invisible barrels.

Unfortunately, I have no idea how to fix it. Other roguelikes usually allow you to change the type of ASCII display, and by fiddling with that I've always been able to get something good enough not to hamper my game in any way. But I don't see any options to change the display type in DoomRL.

Can anyone help me? Do you know of any ways that I can change the display in DoomRL? Or, do you know any ways I can configure Windows so that DoomRL will display properly?

If anyone can help me, I would REALLY appreciate it.

Thanks!
« Last Edit: January 14, 2010, 16:09 by action52 »
Logged

yns88

  • Lance Corporal
  • *
  • Offline Offline
  • Posts: 24
  • Lost Soul
    • View Profile
Re: Display problems--HELP!!
« Reply #1 on: January 13, 2010, 23:10 »

1. Go to DoomRL.ini, set AllowHighAscii to FALSE

If this doesn't work, then you'll have to change your console font. Here's a guide:
http://www.labnol.org/software/tutorials/change-font-dos-command-prompt-window-consolas-programming-font/3253/
Logged

Thomas

  • DoomRL Wiki and Testing Ops
  • Elder Chaos Guard
  • Major General
  • *
  • *
  • Offline Offline
  • Posts: 881
  • How's it going?
    • View Profile
Re: Display problems--HELP!!
« Reply #2 on: January 14, 2010, 09:38 »

I had the same problem and all I needed to do was execute "doomrl.bat" instead of "doomrl.exe".
Logged
Arch-Vile Chaos Major Thomas
[26/26/26/25/9/1]
Medals: 35/43 Specials: 69/67 Assemblies: 36/40

action52

  • Elder
  • Sergeant
  • *
  • *
  • Offline Offline
  • Posts: 62
  • Lost Soul
    • View Profile
Re: Display problems--HELP!!
« Reply #3 on: January 14, 2010, 16:08 »

I actually managed to fix it, using a different solution: I clicked on the window's properties, then changed the font. Now it works fine. The only thing is that the forward slash is still represented by a yen symbol, but the only thing I've encountered that uses this is the combat knife, which arguably looks closer to the real thing with a yen symbol.

Thanks for your suggestions though! I am really enjoying this game now. My third character has made it to Hell Arena, and as I get the hang of maneuvering and reloading it just gets more and more fun.
« Last Edit: January 14, 2010, 16:13 by action52 »
Logged
Pages: [1]