Chaosforge Forum

  • March 28, 2020, 23:51
  • Welcome, Guest
Please login or register.



Login with username, password and session length
Pages: [1]

Author Topic: Controls gone crazy  (Read 2687 times)

CaioMGA

  • Private FC
  • *
  • Offline Offline
  • Posts: 6
  • Lost Soul
    • View Profile
Controls gone crazy
« on: January 17, 2014, 08:22 »

Hi,

I have just found DoomRL and it is a pretty neat game.
But, the controls get crazy after some time playing.
I don't know how much time before messing the controls.
It occured in my 4 (and so far the only 4) sessions playing the game

I noticed the bug when trying to go downstairs and the '>' command does not work.
I tried other commands to get out and none worked. Those are the malfunctioning commands:
'esc'
'S'
'>'
'?'


I still can walk, change weapons and shoot in the game.
I did not tested all the commands, there could be more messed controls.

I use an netbook Acer Aspire One AO722 and a Brazilian usb keyboard (keys layout is ABNT2). The problem occurs on both keyboards, the 'native' from the netbook and the usb one.

If there is any log file that I can post, let me know and I will post it here.
If there is a solution, please, let me know.

[]'s

Caio


----

UPDATE:
It happenned again, this time I got some screenshots. In the pictures below I tried the '>' comand and I got that messages. The screenshots are from the same level.

http://twitpic.com/dskn0k
http://twitpic.com/dskn2p

When trying the 'S' command, message reads "Unknown command, type '?' for help", but when I type '?' I got the same message.

Also, alt + f4 does not work as well, I don't know if it is supposed to work. Anyway...

[]'s
« Last Edit: January 21, 2014, 20:48 by CaioMGA »
Logged

Sylph

  • Elder
  • Captain
  • *
  • *
  • Offline Offline
  • Posts: 298
  • Galaxy Angel
    • View Profile
Re: Controls gone crazy
« Reply #1 on: January 17, 2014, 09:41 »

Sometimes modifier keys (shift, ctrl, alt) can 'stick'. I get it when alt-tabbing - when I go back into doomrl, the alt key thinks it's pressed down...

Try pressing alt, shift, and control (on both sides of the keyboard), that should unstick them if any of them are stuck. :)
Logged
[0.9.9.7G] Arch-Vile Marshall : [26|22|20|16|8|2]

LuckyDee

  • Sound Wizard
  • Grand Inquisitor
  • General
  • *
  • *
  • Offline Offline
  • Posts: 1508
  • High Caliber Consecrator
    • View Profile
    • LuckyDeeIndustries
Re: Controls gone crazy
« Reply #2 on: January 17, 2014, 09:59 »

The keyboard language settings maybe? I know that, if you have multiple options active, there's some stupid frequently-accidentally-pressed combination of keys that changes this. I used to have this when I still had both Dutch and English installed, and it would switch positions of certain symbols like = + / > and such.

Bear in mind that:
- 'esc' has no function
- 'S' only works on the stairs

The other issues may be caused by just this setting, since they occur with symbol keys. It would explain why you are still able to use arrow and letter keys normally.
Logged
[0.9.9.7G] Current: Hell Knight 1st Lieutenant [20/12/4/0/0/0]
High: Arch-Vile Lt. Colonel [25/21/12/2/1/0]

CaioMGA

  • Private FC
  • *
  • Offline Offline
  • Posts: 6
  • Lost Soul
    • View Profile
Re: Controls gone crazy
« Reply #3 on: January 17, 2014, 18:33 »

Sometimes modifier keys (shift, ctrl, alt) can 'stick'. I get it when alt-tabbing - when I go back into doomrl, the alt key thinks it's pressed down...

Try pressing alt, shift, and control (on both sides of the keyboard), that should unstick them if any of them are stuck. :)

Nope. Keys are working properly outside the game.
I have updated the Original Post with more info.

thanks anyway
Logged

CaioMGA

  • Private FC
  • *
  • Offline Offline
  • Posts: 6
  • Lost Soul
    • View Profile
Re: Controls gone crazy
« Reply #4 on: January 17, 2014, 18:46 »

The keyboard language settings maybe? I know that, if you have multiple options active, there's some stupid frequently-accidentally-pressed combination of keys that changes this. I used to have this when I still had both Dutch and English installed, and it would switch positions of certain symbols like = + / > and such.

Bear in mind that:
- 'esc' has no function
- 'S' only works on the stairs

The other issues may be caused by just this setting, since they occur with symbol keys. It would explain why you are still able to use arrow and letter keys normally.

No, the language setted is PT-BR (Brazilian Portuguese) and did not change.

'esc' does have a function, it cancels commands such as 'i', or 'f' or 'e'
I am having trouble when using 'S' over a stair.

So it is not about symbol keys.

I will try to fool around with lua.

Any suggestions or advices?
Logged

LuckyDee

  • Sound Wizard
  • Grand Inquisitor
  • General
  • *
  • *
  • Offline Offline
  • Posts: 1508
  • High Caliber Consecrator
    • View Profile
    • LuckyDeeIndustries
Re: Controls gone crazy
« Reply #5 on: January 18, 2014, 00:55 »

'esc' does have a function, it cancels commands such as 'i', or 'f' or 'e'
I am having trouble when using 'S' over a stair.

OK, since you know what you're doing we can rule out ignorance :)
(No offence meant of course, ignorance is the #1 cause of errors that I run into myself, so it's best to check for that first)

What strikes me as strange is that - if I understand you correctly - everything works fine at the start, then changes during the game. I have no actual knowledge of how the game itself works, but I have a hunch it's not the game that's causing the problem.

To make sure it's not the keyboard settings, have you tried purposely switching in-game? The combos should be either CTRL+SHIFT or L.ALT+SHIFT for both WinXP and Win7. You can easily test this by just mucking about with these on the first level.
Logged
[0.9.9.7G] Current: Hell Knight 1st Lieutenant [20/12/4/0/0/0]
High: Arch-Vile Lt. Colonel [25/21/12/2/1/0]

thelaptop

  • Chaos Fanatic!
  • Grand Inquisitor
  • Apostle
  • *
  • *
  • Offline Offline
  • Posts: 2474
  • Grumpy Admin
    • View Profile
Re: Controls gone crazy
« Reply #6 on: January 18, 2014, 03:05 »

I don't believe it is the "soft" keyboard layout -- it's probably related to the scan codes that the keyboard is generating.  I only say this because it is noted that the keyboard used is based on the ABNT2 layout.  If I remember correctly, DoomRL registers key presses via the scan codes, and I think those scan codes are related to US/US-international keyboards.  This means that something as simple as "SHIFT-S" may require something weird on the actual keyboard, regardless of the set "soft" layout.

I don't have access to my machines with source code access now, or I can give a more concrete verification/answer.  Sorry.  One way to test out this is to use a US keyboard and see if the issues still occur.
Logged
I compute, therefore I am.

Hell Baron 1st Lieutenant (0.9.9.7)
[20/12/8/0/0/0]

CaioMGA

  • Private FC
  • *
  • Offline Offline
  • Posts: 6
  • Lost Soul
    • View Profile
Re: Controls gone crazy
« Reply #7 on: January 18, 2014, 09:18 »

( ... ) it's probably related to the scan codes that the keyboard is generating.  I only say this because it is noted that the keyboard used is based on the ABNT2 layout.

The problems can't be the scan codes.

Controls work just fine in the early-game, but suddenly they crash.

If the problem was the scan codes, it would not work in the first level as well. The keyboard is sending the same 'signals'.

Anyway, I will try the US layout and see if any bugs occur
« Last Edit: January 18, 2014, 09:20 by CaioMGA »
Logged

CaioMGA

  • Private FC
  • *
  • Offline Offline
  • Posts: 6
  • Lost Soul
    • View Profile
Re: Controls gone crazy
« Reply #8 on: January 18, 2014, 09:41 »

OK, since you know what you're doing we can rule out ignorance :)

Ok...

To make sure it's not the keyboard settings, have you tried purposely switching in-game? The combos should be either CTRL+SHIFT or L.ALT+SHIFT for both WinXP and Win7. You can easily test this by just mucking about with these on the first level.

After your suggestion I tried them.
And surprisingly, I got the messed controls at my first run, on the 3rd level.

I did it again, to be sure it was not just a coincidence.
In fact, it was.
I could not replicate it on my second run.
I decided to just play it in a more aggressive way:  Running trough enemies with the chainsaw and killing everything, keeping my fingers away from the shift and ctrl keys. I got the messed controls eventually.

I have a very safe gameplay, different from the berserker that also gave me bad controls.

The bug seems random.

I was playing in fullscreen, so I tried to "alt+tab" during my sessions, maybe it could mess the controls.
Again, no effect. I got the messed controls on just playing it.

I will play with US layout, in my ABNT2 keyboard.
I will post the results of the experiment later.

Thanks for your help
Logged

Equality

  • Second Lieutenant
  • *
  • Offline Offline
  • Posts: 174
  • Lost Soul
    • View Profile
Re: Controls gone crazy
« Reply #9 on: January 19, 2014, 21:37 »

have a such problem too, but because of changing keyboard layout and language. No, if switch to windowed, language indicated as "EN", but after pressing switch language keys, all becomes right. So: do not press keys for switch your language in game. If suddenly game do not react as usual try swith languages if you have some.

Scan-codes have no meaning here, only "windows keys".

Keyboard -> scan codes -> windows translation -> game. If layout or input language changed the game got "invalid" keys
Logged
Once advanced DoomRL player
Find mysterious sword Dragonslayer
Say "Best thing ever found!" and start jumping around...
But he can't get the sword from the ground

CaioMGA

  • Private FC
  • *
  • Offline Offline
  • Posts: 6
  • Lost Soul
    • View Profile
Re: Controls gone crazy
« Reply #10 on: January 21, 2014, 20:40 »

No more messed controls!

Before I run the game I change the keyboard settings to EN.
Boom! Now my sessions end when I die...not when I crash...
I am working on it...

Thanks for the replies


It looks like it is random.
I got the controls messed again.

Waiting for the next patch...
« Last Edit: January 21, 2014, 20:51 by CaioMGA »
Logged
Pages: [1]