Chaosforge Forum

  • September 23, 2023, 21:46
  • Welcome, Guest
Please login or register.



Login with username, password and session length
Pages: [1]

Author Topic: DRL won't compile with default settings  (Read 893 times)

Vid-szhite

  • Lance Corporal
  • *
  • Offline Offline
  • Posts: 23
  • Pistols are my babies <3
    • View Profile
DRL won't compile with default settings
« on: May 27, 2023, 21:12 »

I'm interested in keeping this game alive and adding some features to my own personal version of the game, but while I've got Lua experience, I've got no experience programming in Pascal, so first I decided to try compiling a fresh batch of DoomRL Source Code to make sure I knew that was working.

I followed the instructions on the GitHub exactly: https://github.com/chaosforgeorg/doomrl

I installed the latest 32-bit version of Lazarus, as instructed. I managed to put the Valkyrie libraries in the right place, and the program found them, so that was promising.

The problem is, when I clicked Build after opening src/makewad.lpi, it gave me an error, and I suspect this is why the instructions tell you to use 32-bit Lazarus:

Quote
vconui.pas(411,20) Error: Can't determine which overloaded function to call

A google search told me that this is related to the compiler trying to build it in 64-bit and having two options for which data type to use and not being able to decide. However, the search results also stated it does compile in 32-bit Lazarus...

4 years ago.

Unfortunately, I triple-checked that I am in fact using 32-bit Lazarus, I even tried using an older version dated to Jan 5 2022, and when that also failed, I used many options in the menus to try and get it to compile a 32-bit program. None of them worked. Unfortunately, I am using 64-bit Windows, so maybe that's the issue...

Unfortunately, this means the instructions are incomplete, and I can't create makewad.exe. Without these files, any changes or updates I try to make to the source code would be pointless, so I'm afraid I can't continue unless somebody knows a workaround.

Can somebody help me?

EDIT: I may have figured it out. Cross-compiler instructions may be needed. https://wiki.lazarus.freepascal.org/Cross_compiling#From_win64_to_win32

I'll try this and update later.

EDIT 2: NOPE. That did not work. Exact same problem.
« Last Edit: May 29, 2023, 03:46 by Vid-szhite »
Logged
Ya Girl Juniper - DoomRL 0.9.9.7 Cyberdemon Major

Check out my DoomRL SoundPack: https://forum.chaosforge.org/index.php/topic,8031.0.html

Vid-szhite

  • Lance Corporal
  • *
  • Offline Offline
  • Posts: 23
  • Pistols are my babies <3
    • View Profile
Re: DRL won't compile with default settings
« Reply #1 on: June 23, 2023, 09:14 »

I had an idea! Could someone else with access to 32-bit Windows compile makewad.exe for me, using the instructions on the github? That's all I need, really. If I had that, I might be able to do the rest myself and start seeing what I can do! Maybe even start adding some content. Been dying to try.
Logged
Ya Girl Juniper - DoomRL 0.9.9.7 Cyberdemon Major

Check out my DoomRL SoundPack: https://forum.chaosforge.org/index.php/topic,8031.0.html

Kornel Kisielewicz

  • God Hand
  • Apostle
  • *
  • *
  • Offline Offline
  • Posts: 4556
    • View Profile
    • http://chaosforge.org/
Re: DRL won't compile with default settings
« Reply #2 on: June 25, 2023, 07:09 »

Hey, use the development branch of both doomrl and fpc valkyrie - should compile both in 32 and 64 bit without issues.
Logged
at your service,
Kornel Kisielewicz
Pages: [1]